博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ 1328 Radar lnstallation 2
阅读量:5971 次
发布时间:2019-06-19

本文共 2254 字,大约阅读时间需要 7 分钟。

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
贪心:注意重点
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int f[1010];
struct aa
{
    double x,y;
}a[1010];
int cmp(aa q,aa w)
{
    return q.x<w.x;
}
int main()
{
    int k,n,m,cnt,ka=0;
    while(cin>>n>>m)
    {   if(n==0&&m==0)break;
        ka++;
        int flat=1;
        k=0;
        double x,y,c,mm=(double)m*m;
        for(int i=1;i<=n;i++)
        {
          cin>>x>>y;
          if(m>=y)
          {c=sqrt(mm-y*y);
           a[++k].x=x-c;
           a[k].y=x+c;
          }
          else
         {
             flat=0;
          }
        }
        getchar();
        if(flat)
        {sort(a+1,a+k+1,cmp);
        double now = a[1].y;
         cnt = 1;
        for(int i=2;i<=k;i++)
        {
          if(a[i].y<now)
            now=a[i].y;
          else if(a[i].x>now)
          {
              cnt++;
              now=a[i].y;
          }
        }
        }
        else
        cnt=-1;
        cout<<"Case "<<ka<<": "<<cnt<<endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/552059511wz/p/6569155.html

你可能感兴趣的文章
ASP.NET 运行机制详解
查看>>
在 ML2 中配置 OVS vlan network - 每天5分钟玩转 OpenStack(136)
查看>>
Selenium2+python自动化34-获取百度输入联想词
查看>>
【★★★★★】提高PHP代码质量的36个技巧
查看>>
如何解决/home/oracle: is a directory报警
查看>>
BaaS API 设计规范
查看>>
bootloader功能介绍/时钟初始化设置/串口工作原理/内存工作原理/NandFlash工作原理...
查看>>
iOS开发UI篇—Quartz2D使用(矩阵操作)
查看>>
C++ 构造函数与析构函数
查看>>
Python快速教程
查看>>
ssh免密码登录
查看>>
Linux下Django环境安装
查看>>
如何在指定的内容中找出指定字符串的个数
查看>>
我的友情链接
查看>>
浅谈如何用We7站群平台打造垂直性政务网站
查看>>
我的友情链接
查看>>
Go bytes包
查看>>
Spring MVC请求处理流程分析
查看>>
生产环境MySQL 5.5.x单机多实例配置实践
查看>>
Web应用工作原理、动态网页技术
查看>>